Current time: 12-11-2017, 04:49 AM
Question Theme with Background Image - Problem on non-standard Forum Pages
07-14-2012, 13:34 PM
Post: #1
Theme with Background Image - Problem on non-standard Forum Pages
Hi guys, i am using the Battlefield - Bad Company theme currently for testing on my board. It has a fixed forum background image instead of just a forum background color. Which shows with all standard forum links.

But as soon as I go to a plugin, meaning a link that isn't standard MyBB url, the background image of the forum is gone.

Any kinda Mod that has its own php file, as soon as I click on that, the background is gone. Is that changable somehow so the forum background shows all the time ?

Example:

Standard Forum view

http://i.imgur.com/BvQDM.jpg

And here in for example the Donation plugin (also happens with other non-standard Forum pages)

http://i.imgur.com/NwA7E.jpg

The background image is gone. Why is that ?


Additonally:
I wasn't sure if I wanted to stay with that background Image the Themes comes with. So I tried to change that in the .css into a background color, but i can't find anything about the so called "background.png" in the global or the other .css files.

The only thing in the global.css file that relates to something with an image, is that.

Quote:The contents of this section are hidden from your usergroup.

Register

When you remove that, the background image is gone. But the image is not even named in there, so where does it get the information from to take the background.png as image ? Sad

I can't reach the guy that made the Theme, already tried. If anyone knows how I can change that so its using a background color instead of the background image, please let me know. If i would just know where the picture location is taken from.
This attachment is locked until you reply to this thread. Become a subscriber and all annoying adf.ly links will be removed.
Quote

Namecheap.com

07-14-2012, 13:53 PM
Post: #2
RE: Theme with Background Image - Problem on non-standard Forum Pages
The image will be hard coded in one of your templates, most likely your index template as the image is not displaying on any other page other than the index. You'll see something like this:

<img class="backGroundImg2" src="background.png" />

The contents of this section are hidden from your usergroup.

$10 Off any hostgator package - Coupon Code: The contents of this section are hidden from your usergroup.
25% Off any hostgator package - Coupon Code: The contents of this section are hidden from your usergroup.
$25 Off all reseller packages - Coupon Code: The contents of this section are hidden from your usergroup.
Quote

Namecheap.com

07-14-2012, 18:15 PM
Post: #3
RE: Theme with Background Image - Problem on non-standard Forum Pages
(07-14-2012 13:53 PM)Echo Wrote:  The contents of this section are hidden from your usergroup.

Register
Is there a way t search for something specific throuh all templates like i can in vB ?

Wolf
Quote

Namecheap.com

07-14-2012, 18:17 PM
Post: #4
RE: Theme with Background Image - Problem on non-standard Forum Pages
In ACP:

   

The contents of this section are hidden from your usergroup.

$10 Off any hostgator package - Coupon Code: The contents of this section are hidden from your usergroup.
25% Off any hostgator package - Coupon Code: The contents of this section are hidden from your usergroup.
$25 Off all reseller packages - Coupon Code: The contents of this section are hidden from your usergroup.
Quote

Namecheap.com

07-14-2012, 18:58 PM
Post: #5
RE: Theme with Background Image - Problem on non-standard Forum Pages
Ok, i have found that what you posted above in quite many templates. Lets say I want to remove all these lines, would be some work but doable. But then what. How do I specify that area where the background image was, with a background color ? I mean in which part in the global.css ?

Here the global.css.

http://paste2.org/p/2073255
Quote

Namecheap.com

07-14-2012, 19:04 PM
Post: #6
RE: Theme with Background Image - Problem on non-standard Forum Pages
Place your background image in your "body" tag.

The contents of this section are hidden from your usergroup.

$10 Off any hostgator package - Coupon Code: The contents of this section are hidden from your usergroup.
25% Off any hostgator package - Coupon Code: The contents of this section are hidden from your usergroup.
$25 Off all reseller packages - Coupon Code: The contents of this section are hidden from your usergroup.
Quote

Namecheap.com

07-14-2012, 19:21 PM (This post was last modified: 07-14-2012 19:34 PM by Wolfseye.)
Post: #7
RE: Theme with Background Image - Problem on non-standard Forum Pages
The thing is, I want to go without a background image. So I am removing now all the image lines mentioned above from the templates and gave the body a background color.

With some templates it was no problem, with some on the other hand there were problems when I wanted to edit them. Some showed the following error when I wanted to save the changed template, from which I only removed that one line.

Quote:The contents of this section are hidden from your usergroup.

Register

The error it shows is.

The following errors were encountered:

A potential security issue was found in the template. Please review your changes or contact the MyBB Group for support.

And even if I readd the line I wanted to remove, it still keeps up with the error.

UPDATE:

To save time, i replaced it in all (but 2) templates with a simple dot. Doesn't really show and saved time, removing it manually from all the templates. But still, 2 templates I can't change.

- calendar (http://paste2.org/p/2073287)
- calendar_weekview (http://paste2.org/p/2073284)
Quote

Namecheap.com



Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  i keep getting this in my forum polopolo 1 372 11-18-2016 20:49 PM
Last Post: polopolo
  [How To?] How can I add a background changer to my theme? Technologx 0 471 04-28-2016 02:33 AM
Last Post: Technologx
  [Question] CSS problem on teslagame theme FlowZ 0 532 02-16-2016 16:29 PM
Last Post: FlowZ
  [Error Message] Forum Off wcampos 20 4,611 08-11-2013 16:33 PM
Last Post: nebulos
  Server load mysterious problem hady 10 2,857 03-29-2013 20:55 PM
Last Post: hady


User(s) browsing this thread: 1 Guest(s)